Diary--/*isaji*/MIDI Lab.

<< 2017/05 | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 >>

kazehakase 0.3.1 2005-09-29 [permalink] [?B] はてなブックマーク

というわけで、昨日久しぶりに風博士がまともに動いたものの、結局今日は肉の日ですので、リリースされた0.3.1をインストール。

GPLなのにOpenSSLを利用するのはライセンス上問題があるという事で、今回からGnuTLSに変更されているようです。

これのおかげですんなりmakeが通らなくて困りましたけど。

うちのメイン環境は現在Fedora Core 4なんですけどね、インストールされているgnutlsのバージョンは1.0.25-1です。これだとバージョンが古いですよ~ってコンフィギャで怒られる。makeも通らない。どうも1.2.0以上が必要なご様子。

aptで入れようにもリポジトリに無いようなので、どっかで拾ってきた1.2.6-1のsrc.rpmを喰わせました。

いや、rpm searchで探して落としてきたってだけなんですけどね。

rpmbuild --rebild --target=athlon gnutls-1.2.6-1.src.rpmみたいにして出来たrpmを片っ端からrpm -Uvh

しようと思ったら依存関係でインストール出来なかったので、--replacefilesオプション付きで。ちょっと強引だったかも。

rpm --replacefiles -Uvh gnutls-1.2.6-1.athlon.rpm
gnutls-devel-1.2.6-1.athlon.rpm
gnutls-utils-1.2.6-1.athlon.rpm

あとはいつも通り風博士をconfigure; make; make install.

どーにかなるもんですね。

Linux - | comments (0) | trackbacks (0)